Author Topic: Can't navigate using directional keys in editing mode (stz2006/list editor)  (Read 5387 times)

0 Members and 1 Guest are viewing this topic.


  • Newbie
  • *
  • Posts: 13
    • View Profile
Hi, firstly congratulations on a great product  :)

This bug applies to both the demo version of stackz 2006 and the list editor. I am currently trying to create a list of Korean vocab/grammar structures so i have set the language of the file to 'korean (Ansi)' in the options file.  When using the 'Edit' window (F2) or using the 'edit current entry'in the 'Test' window (F4) the directional arrow keys, backspace,delete and enter keys do not work. As you can imagine, this makes entering and editing text quite difficult (if i want to delete something then i have to highlight the text I wish to delete with the mouse and then ctrl-x to cut it)

If i change the default language of the file to Chinese,English or Japanese then i can use the directional buttons, backspace and delete (escape just prints a box, however this doesnt really bother me as i have no use for the escape key).

If the language is set to Chinese or Japanese then the Korean characters do not display correctly, however if the language is set to English then they appear to display correctly (I have not exhaustively tested if everything displays correctly under English mode, i just did a quick check before writing this).

I also have similar problems when using the list import wizard. When set to korean then the above mentioned keys no longer function.

English language windows XP Professional (Service pack 2)
Language toolbar installed to enable korean character input
Stackz 2006 demo version
Stackz List Editor 2005 v3


  • Administrator
  • Sr. Member
  • *****
  • Posts: 431
    • View Profile
Thank you for reporting that problem.

"not working" - do you mean that there is simply no reaction at all? I am very surprised about that. It has always worked on my PC and there was no problem when I checked this morning and this problem has never been reported in the past.

  • Are you sure that Korean support works properly on your system with other applications?
  • I assume that your "Language Toolbar" is the IME provided by XP (MS-IME 2002) and that it is active during your activities. Is there a difference in behavior with disabled Korean Input? Maybe removing and reinstalling this one helps?
  • Did you change anything in the Stackz font assignment of Korean text? Please try hitting the "Reset Languages" button in the Stackz Language dialog (Menu Options -> Stackz Options) to try reverting to a working configuration.
  • Do you have the chance to try Stackz on a different PC? Maybe there is some other sort of side-effect that only appears with a certain configuration.

Question to the other users: Did anybody experience a similar behavior?

If all fails, please upload a small sample file, maybe it contains some further indication of the problem that I can investigate.


  • Newbie
  • *
  • Posts: 13
    • View Profile
wow, thank you for the fast turnaround in replying!
To address your questions:
* Indeed korean language support works in other applications. I commonly use it in mozilla firefox/thunderbird as well as openoffice.
* You assume correctly, I am using the default MS-IME 2002 toolbar.
* Tried hitting reset languages, still the same result.
* Just installed the demo on my girlfriends laptop and got the same results.

I also just realised that while the 'english' option will display the korean text, it will not allow the entry of new korean text (trying to type korean displays nothing, and if i try to paste korean then it just comes up as a series of question marks).

I have also sent you a private message with further information.
Kind Regards,

Note: the image isnt displaying on the page "".
« Last Edit: June 25, 2006, 02:30:30 PM by poita »